现在使用opencart做商城的用户还是挺多的,目前还有大部分仍然使用老版的1.5版本,自从升级2.0版本以后,功能和扩展性整体都在提高,那么有的用户就想着把1.5的版本升级到2.0以后,目前官方也推出了相关的升级插件,但是在网上看了一下,有许多用户出现在升级的过程中页面空白的现象,刷新以后也没有什么反应,下面我就来说一下这种方法要怎么解决。

因为我之前帮朋友升级opencart1.5.6到2.1的时候,也遇到过类似的情况,尝试了各种更换pHP版本或者是数据库版本问题仍然没有解决,最后在无意中我把插件目录给删除以后居然升级成功了,明显就是所安装的插件有冲突,那么到底是哪个插件再起冲突呢?经过逐一的排查以后,确定是opencart的缓存插件有问题,只要把这个插件停用或者暂时删除再升级就没有问题,等把程序升级成功以后再重新启用插件就好。